glitter's Q2GUNFRENZY!-2-

This release requires Quake2 v3.20 & the latest ACT LABS GS driver (for non-USB guns) to play - links for both can be found from the game launcher.  For detailed driver upgrade instructions and other info, check the ReadMe file from the Launcher.


Click to download GF2.

Click to download the 2.1 Beta Patch.


















(c) gl.tter 1999 updated: 24 Dec 1999